Degraded uploads performance. We are currently investigating the issue to identify a fix.
Incident Report for Strava
Resolved
This incident has been resolved.
Posted 4 months ago. Aug 05, 2018 - 18:01 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted 4 months ago. Aug 05, 2018 - 03:12 PDT
This incident affected: Upload.